Welcome to the 2GNT Forum! Interested In Advertising with 2GNT?
Home | Site Background| Info&Specs| Mods & Tech Info | CAPS | Part Reviews | Donate | 2GNT Stickers |
Search Printer-friendly copy Email this topic to a friend 3 Users in Chat
Top 2GNT Technical Performance/Engine Engine Management Systems & Controllers topic #2549
View in linear mode

Subject: "RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!" Previous topic | Next topic
WickedESiApr-18-07 01:10 PM
Donating 2GNT member
3090 posts,
Click to send email to this author Click to send private message to this author Click to view this author's profile Click to add this author to your buddy list
#3140, "RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!"
In response to In response to 9
Apr-18-07 01:15 PM by WickedESi



          

If you STILL are getting spikes (or if you are getting spikes running as a piggyback). First make sure your MS case isn't bolted down to (or touching) a metal part of your car (you just created a ground loop).

The following post from the MSnS forum has helped tons of people (including me ridding of the random intermittent spikes I was getting on random sensors) by fixing a design flaw on the v3 board when used in electronically noisy environments (i.e. automobiles). Even if you have done nothing else, I've mentioned, on any v3 board setup. If you are having any kind of resets/spikes I recommend doing the following:


The processor resets that I have experienced in MS1 have all been in connection with either disturbances in the power supply or radiated/conducted disturbances finding their way to pin 6 RSTinv. I would try the following ( observing the + 5V on a scope would be a great help)

Power supply/ injectors
Make sure that + and ground leads are of decent size and that no major ground loops exists. (There was a recent post which got rid of disturbances by electricaly isolating the MS box from the firewall !)
Arrange so that the flyback + feed is separated from the +12V in feed to the MS(several posts exists on this )
Try out a LC filter in the +lead

CPU
Install 100nF mylar caps directly between pins 1/2 , 19/20 and 31/32.
Solder the caps directly on the socket pins. This could help the +5V
Install a 100nF cap between pin 6(RSTinv) and a ground very close by .
Pin 6 is quite sensitive to disturbances. Even a scope probe of 50Mohms/8pF which is touched to pin 6 will cause a reset.
With the 100nF cap added the RSTinv (pin6) becomes quite insensitive.


I have tried all of the above on different installations and especially the PWM recirkulation/flyback peak and the pin 6 have caused resets for me .

Best regards
Heribert


Joel Baldridge, ASE Certified Master Technician, Audi Certified Expert Technician

  

Report This Post to Admin Printer-friendly copy | Reply | Reply with quote

Running MSnS v3 Board as FULL Standalone (No Spikes)! [View all] , WickedESi, Sep-04-06 03:52 PM
  RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, WickedESi, Sep-04-06 04:55 PM, #1
RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, WickedESi, Sep-04-06 06:29 PM, #2
      RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, gilee_8, Sep-05-06 08:38 AM, #3
      RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, WickedESi, Sep-05-06 10:30 AM, #4
           RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, gilee_8, Sep-06-06 10:31 AM, #5
                RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, WickedESi, Sep-06-06 06:52 PM, #6
                     RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, gilee_8, Sep-07-06 05:41 AM, #7
                          RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, gilee_8, Sep-11-06 04:11 PM, #8
                               RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, Chamuko, Sep-12-06 10:58 AM, #9
                                    RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, WickedESi, Apr-18-07 01:10 PM #10
                                         RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, Teametx, Aug-16-07 01:59 PM, #11
                                              RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, WickedESi, Aug-16-07 03:27 PM, #12
                                                   RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, Teametx, Aug-22-07 05:41 AM, #13
                                                        RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, Teametx, Aug-27-07 03:23 PM, #14
                                                             RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, Teametx, Aug-30-07 04:23 AM, #15
                                                                  RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, WickedESi, Aug-30-07 12:53 PM, #16
                                                                       RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, Teametx, Aug-31-07 04:43 AM, #17
                                                                            RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, WickedESi, Sep-01-07 09:13 AM, #18
                                                                                 RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, Teametx, Sep-04-07 04:06 PM, #19
                                                                                      RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, WickedESi, Sep-06-07 03:11 PM, #20
      RE: Running MSnS v3 Board as FULL Standalone (No Spikes)!, PinkPixi, Apr-15-12 01:42 AM, #21

Top 2GNT Technical Performance/Engine Engine Management Systems & Controllers topic #2549 Previous topic | Next topic
Powered by DCForum+ Version 1.2
Copyright 1997-2003 DCScripts.com

I generated this page in 0.059767961502075 seconds, executing 14 queries.