Welcome to the 2GNT Forum! Interested In Advertising with 2GNT?
Home | Site Background| Info&Specs| Mods & Tech Info | CAPS | Part Reviews | Donate | 2GNT Stickers |
Search Printer-friendly copy 0 Users in Chat
Top 2GNT Technical Handling/Suspension topic #33854
View in linear mode

Subject: "Been awhile. Back with another 99 OZ eclipse gs" Previous topic | Next topic
cragsterJun-30-18 03:56 PM
Member since Dec 16th 2007
6 posts,
Click to send email to this author Click to send private message to this author Click to view this author's profile Click to add this author to your buddy list
#33854, "Been awhile. Back with another 99 OZ eclipse gs"


          

Hey guys been forever since I been here surprised I remembered my password and username lol. Anyway I picked up a 1999 eclipse oz auto for my wife for 385 bucks.
Towed it home I got it to start by jumping the battery. I found some bad fuses including the 120 all alternator fuse. Fixed that and it starts right up. Still has a lot of issues though.
The rear driver side wheel looks like it is angled inward the other 3 tires look straight like normal. Also the rear end feels terribly bouncy. I'm gonna post a pic of this tire. Looking to know what you think I should check first.

'97 Eclipse GS

  

Report This Post to Admin Printer-friendly copy | Reply | Reply with quote | Top
Top 2GNT Technical Handling/Suspension topic #33854 Previous topic | Next topic
Powered by DCForum+ Version 1.2
Copyright 1997-2003 DCScripts.com

I generated this page in 0.085381031036377 seconds, executing 12 queries.