Welcome to the 2GNT Forum! Interested In Advertising with 2GNT?
Home | Site Background| Info&Specs| Mods & Tech Info | CAPS | Part Reviews | Donate | 2GNT Stickers |
Search Printer-friendly copy Email this topic to a friend 0 Users in Chat
Top 2GNT Technical Handling/Suspension topic #26438
View in linear mode

Subject: "RE: Problem with AEM 12.5" rotor upgrade" Previous topic | Next topic
thedawgApr-08-05 10:43 AM
Donating 2GNT member
6287 posts,
Click to send email to this author Click to send private message to this author Click to view this author's profile Click to add this author to your buddy list
#26803, "RE: Problem with AEM 12.5" rotor upgrade"
In response to In response to 0
Apr-08-05 11:15 AM by thedawg

          

Ok, I just took out my rotors and I see two things you could be having probems with.

1) The bolt holding the caliper bracket to the hub. The AEM? bolts I have are just about 1mm too long if you attempt to mount the hub without using the AEM dogbone. They hit the backside of the rotor, preventing it from seating. Solution here would be to remove everything from the hub, including all brackets to test fit.




Pay REALLY close attention to the dogbone. It can be installed 4 ways, only one works. The nipples should face out, and the larger pair of nipples should face away from the hub. You can also see the 1/8" of grinding I had to do to get the GSX calipers to fit. (bright orange rusted patch)



2) The outside of the hub could be rusted enough to keep the hat from fitting over the hub. (also, it could be rusted on the inside of the hat, where the axle nut goes). But I don't see any ridge on my rotors anywhere, its all rounded to allow for slight rusting of the hub. Solution would be dremeling down the rust buildup on the hub.




The tolerances are very close on the hat, but it fits perfectly on all my FWD cars, from 1995-1999, both turbo and nonturbo, talon and eclipse, both with and without ABS. You two must have a very unique hub, the WRONG AEM PART NUMBER?, or a badly out of tolerance (defective) rotor if it really doesn't just mount up. (My part number is 32-5004, stamped on the front, inside rim of the hat.)



Also, here's how badly the pad hangs off the rotor. You can just barely see a stripe of black at the top center of the pad.



I live 5 minutes from RRE and 15 minutes from AEM headquarters. If you guys would like to ship me your rotors, and I can re-create your problem, I'll take them to both companies and show them exactly what the problem is.

  

Report This Post to Admin Printer-friendly copy | Reply | Reply with quote

Problem with AEM 12.5" rotor upgrade [View all] , got_NX, Feb-24-05 08:05 AM
  RE: Problem with AEM 12.5" rotor upgrade, PowerEclipses, Feb-24-05 02:24 PM, #1
RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Feb-24-05 03:03 PM, #2
      RE: Problem with AEM 12.5" rotor upgrade, thedawg, Mar-07-05 07:54 AM, #3
           RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Mar-10-05 11:30 AM, #4
                RE: Problem with AEM 12.5" rotor upgrade, Moderatorjuan, Mar-10-05 01:16 PM, #5
                RE: Problem with AEM 12.5" rotor upgrade, thedawg, Mar-16-05 06:53 AM, #6
                     RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Mar-26-05 03:05 PM, #7
                          RE: Problem with AEM 12.5" rotor upgrade, got_NX, Mar-28-05 03:24 PM, #8
                               RE: Problem with AEM 12.5" rotor upgrade, thedawg, Mar-29-05 10:45 AM, #9
                                    RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Mar-29-05 10:52 AM, #10
                                    RE: Problem with AEM 12.5" rotor upgrade, thedawg, Mar-29-05 01:29 PM, #11
                                         RE: Problem with AEM 12.5" rotor upgrade, got_NX, Mar-30-05 01:13 AM, #12
                                              RE: Problem with AEM 12.5" rotor upgrade, turbo8u, Mar-30-05 08:54 AM, #14
                                                   RE: Problem with AEM 12.5" rotor upgrade, got_NX, Apr-16-05 12:38 AM, #33
                                    RE: Problem with AEM 12.5" rotor upgrade, got_NX, Mar-30-05 01:16 AM, #13
                                         RE: Problem with AEM 12.5" rotor upgrade, SonicYan, Mar-30-05 09:37 AM, #15
                                              RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Mar-30-05 10:54 AM, #16
                                              RE: Problem with AEM 12.5" rotor upgrade, got_NX, Mar-31-05 01:08 AM, #17
                                              RE: Problem with AEM 12.5" rotor upgrade, SonicYan, Mar-31-05 09:41 AM, #20
                                              RE: Problem with AEM 12.5" rotor upgrade, SilverBullet20g, Mar-31-05 02:11 AM, #18
                                                   RE: Problem with AEM 12.5" rotor upgrade, got_NX, Mar-31-05 02:54 AM, #19
                                                        RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Mar-31-05 10:19 AM, #21
                                                             RE: Problem with AEM 12.5" rotor upgrade, Kaoz78, Apr-05-05 12:09 PM, #22
                                                                  RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Apr-06-05 04:56 PM, #23
RE: Problem with AEM 12.5" rotor upgrade, thedawg, Apr-08-05 10:43 AM #24
RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Apr-08-05 03:35 PM, #25
      RE: Problem with AEM 12.5" rotor upgrade, rhui, Apr-09-05 09:20 AM, #26
           RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Apr-09-05 01:12 PM, #27
                RE: Problem with AEM 12.5" rotor upgrade, thedawg, Apr-11-05 07:49 AM, #28
                     RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Apr-12-05 01:28 AM, #29
                     RE: Problem with AEM 12.5" rotor upgrade, got_NX, Apr-12-05 07:34 AM, #30
                          RE: Problem with AEM 12.5" rotor upgrade, thedawg, Apr-12-05 09:15 AM, #31
                     RE: Problem with AEM 12.5" rotor upgrade, got_NX, Apr-12-05 10:20 AM, #32
                          RE: Problem with AEM 12.5" rotor upgrade, got_NX, Apr-16-05 12:51 AM, #34
                               RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Apr-16-05 01:14 PM, #35
                                    RE: Problem with AEM 12.5" rotor upgrade, got_NX, Apr-17-05 12:58 AM, #36
                                         RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Apr-17-05 01:11 AM, #37
                                              RE: Problem with AEM 12.5" rotor upgrade, thedawg, Apr-18-05 06:11 AM, #38
                                                   RE: Problem with AEM 12.5" rotor upgrade, MCubed45, Apr-19-05 05:02 PM, #39
                                                        RE: Problem with AEM 12.5" rotor upgrade, thedawg, Apr-19-05 06:26 PM, #40

Top 2GNT Technical Handling/Suspension topic #26438 Previous topic | Next topic
Powered by DCForum+ Version 1.2
Copyright 1997-2003 DCScripts.com

I generated this page in 0.10536503791809 seconds, executing 12 queries.